README 751 Bytes
Newer Older
1
2
== Running the test cases in test/multidomain ==

3
4
You need the following releases of the DUNE core modules and 
dune-multidomain(grid):
5
Dune core modules: release 2.3
6
Dune-PDELab: release 2.0
7
dune-multidomaingrid: release branch 2.3
8
dune-multidomain: release branch 2.0
9
10
11
12
13
14
15
16

Install the external grid manager UG. Additional you need to install a
direct linear solver like SuperLU or PARDISO.
You need Boost fusion for dune-multidomaingrid.

There are compiler restrictions:
- GCC 4.6 works.
- GCC 4.7 produces segmentation faults.
17
- GCC 4.8 and 4.9 works only with unoptimized builds (-O0).
18
19
20
21
22
- Clang is not supported.
- Intel ICC is not tested.

For your convenience we provide the Shell script installRequiredModules.sh
in the same folder as this README.