README 749 Bytes
Newer Older
1
2
== Running the test cases in test/multidomain ==

3
You need the following versions of the required Dune modules:
4
5
Dune core modules: 2.4
dune-typetree, dune-multidomaingrid: release (branch) 2.3
6
Dune-PDELab, dune-multidomain: release (branch) 2.0
7
dune-multidomaingrid has to be patched, see patches/README for details.
8

9
10
11
12
13
The necessary modules and the correct versions can be obtained by using
the script located in:
  bin/installexternal.sh

-- Other external packages --
14
Install the external grid manager UG and a direct linear solver like SuperLU
15
or UMFPACK. You need Boost fusion for dune-multidomaingrid.
16

17
18
If you encounter segmentation faults, make sure that UG, all DUNE libraries and
the executable in question are built with the same compiler.
19