Commit 47d743f7 authored by Timo Koch's avatar Timo Koch
Browse files

Merge branch 'feature/python-dune-version' into 'master'

[python] Require dune-common>=2.8 to enable Python bindings

See merge request !2728
parents 50ab721c 4eba179d
Pipeline #6445 failed with stages
in 0 seconds
...@@ -35,8 +35,10 @@ add_subdirectory(examples EXCLUDE_FROM_ALL) ...@@ -35,8 +35,10 @@ add_subdirectory(examples EXCLUDE_FROM_ALL)
# if Python bindings are enabled, include necessary sub directories. # if Python bindings are enabled, include necessary sub directories.
if(DUNE_ENABLE_PYTHONBINDINGS) if(DUNE_ENABLE_PYTHONBINDINGS)
add_subdirectory(python) if(${dune-common_VERSION} VERSION_GREATER_EQUAL 2.8)
dune_python_install_package(PATH "python") add_subdirectory(python)
dune_python_install_package(PATH "python")
endif()
endif() endif()
# finalize the dune project, e.g. generating config.h etc. # finalize the dune project, e.g. generating config.h etc.
......
...@@ -15,5 +15,7 @@ add_subdirectory(timestepping) ...@@ -15,5 +15,7 @@ add_subdirectory(timestepping)
# if Python bindings are enabled, include Python binding tests # if Python bindings are enabled, include Python binding tests
if(DUNE_ENABLE_PYTHONBINDINGS) if(DUNE_ENABLE_PYTHONBINDINGS)
add_subdirectory(python) if(${dune-common_VERSION} VERSION_GREATER_EQUAL 2.8)
add_subdirectory(python)
endif()
endif() endif()
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment