[installexternal.py] Use dune release 2.8 per default

5 jobs for !2927 with kweis-master-patch-46061
latest merge request