Merge branch 'feature/python-dune-version' into 'master'

[python] Require dune-common>=2.8 to enable Python bindings

See merge request !2728
1 job for master in 22 seconds (queued for 6 seconds)
Status Name Job ID Coverage
  Check Status
passed check-pipeline-status #24254

00:00:22