[ci] Use variable to set dune release version to test with

5 jobs for !2781 with feature/ci-use-dune-2.8
detached
Status Name Job ID Coverage
  Trigger
manual full-dune-latest-release-clang
manual full-dune-latest-release-gcc
manual full-dune-master-gcc
manual minimal-dune-latest-release-gcc
 
  Downstream Modules
created trigger lecture