Update to use newer versions of DuMuX and preCICE

Merged Alexander Jaust requested to merge update-ci into develop

Description

The CI is updated to run tests with DuMuX 3.4 and 3.5 and preCICE 2.3.0 and 2.4.0. At night, a test against the current DuMuX master branch is carried out.

Checklist

  • I made sure that the source files are formatted properly.
  • I added my changes to the changelog (CHANGELOG.md)
Edited by Alexander Jaust

Merge request reports