Commit dd1c72fd authored by Christoph Grüninger's avatar Christoph Grüninger
Browse files

Merge branch 'feature/require-cxx14' into 'master'

Enforce support for C++-14

* This requires at least Dune 2.4.1.
* GCC 4.8 does not match this requirement

See merge request !151
parents 00e8f088 756b0985
......@@ -23,6 +23,9 @@ include(DuneMacros)
dune_project()
dune_enable_all_packages()
# enforce C++-14
dune_require_cxx_standard(MODULE "DuMuX" VERSION 14)
add_subdirectory(cmake/modules)
add_subdirectory(doc)
add_subdirectory(dumux)
......
Module: dumux
Version: 2.10-git
Maintainer: dumux@listserv.uni-stuttgart.de
Depends: dune-grid (>= 2.4) dune-localfunctions (>= 2.4) dune-istl (>= 2.4)
Depends: dune-common (>= 2.4.1) dune-grid (>= 2.4) dune-localfunctions (>= 2.4) dune-istl (>= 2.4)
Suggests: dune-alugrid (>=2.4) dune-pdelab (>=2.0) dune-multidomain dune-cornerpoint dune-foamgrid (>=2.4)
Whitespace-Hook: Yes
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment