Commit f060ff97 authored by Dennis Gläser's avatar Dennis Gläser
Browse files

[README] do not instruct to use course install script

parent fd352ca4
......@@ -16,14 +16,24 @@ Depending on whether you already have DuMu<sup>x</sup> installed or not, choose
### Install DuMu<sup>x</sup> together with the course
The easiest way to install everything you need is to follow the steps in the [install script](https://git.iws.uni-stuttgart.de/dumux-repositories/dumux-course/-/blob/master/scripts/README.md).
This will install everything for you to get directly started.
The easiest way to install everything you need is to use the install scripts provided in DuMu<sup>x</sup>,
for instance, with this sequence of commands:
```bash
wget https://git.iws.uni-stuttgart.de/dumux-repositories/dumux/raw/releases/3.5/bin/installdumux.py
python3 installdumux.py --dumux-version 3.5 --dune-version 2.8
python3 dumux/bin/installexternal.py course
./dune-common/bin/dunecontrol --opts=./dumux/cmake.opts all
```
If you don't have `wget` and don't want to install it, you can just manually download the
`installdumux.py` script from the git repository.
### Install the course into your existing DuMu<sup>x</sup> project
If you already have an installation of DuMu<sup>x</sup>,
navigate to your common DuMu<sup>x</sup> root directory `cd yourInstallationFolder/dumux` and then run the following commands:
navigate to your DuMu<sup>x</sup> root directory `cd yourInstallationFolder`
and then run the following commands:
```bash
python3 dumux/bin/installexternal.py course
......@@ -33,5 +43,18 @@ python3 dumux/bin/installexternal.py course
This will download and then configure the course repository using `dunecontrol`.
After this, you can start with the [exercises](https://git.iws.uni-stuttgart.de/dumux-repositories/dumux-course/-/tree/master/exercises).
### Requirements
For a successful installation and the execution of all exercises, the following
requirements are needed:
* gcc >= 7
* cmake >= 3.13
* git
* pkg-config
* paraview (to visualize the results)
* gnuplot (to plot some curves)
* wget (to download some config files during the installation)
Last updated for: __DuMu<sup>x</sup> release 3.4 in June 2021__.
Last updated for: __DuMu<sup>x</sup> release 3.5 in May 2022__.
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment